TC2 Errors

Incident Report for Resideo

Monitoring

Thank you for your continued patience as we work to implement a resolution for the issues being experienced with the TC2 application and linked cameras. We are in the process of pushing new Firmware to impacted VX1 and VX3 devices.

We will provide an update once fully resolved, thank you for your patience and we apologize for the inconvenience.
Posted Jul 31, 2026 - 18:20 UTC

Update

We are currently testing updates to the VX cameras on the TC2 application to resolve the intermittent issues.

We will provide an update when testing is completed and full deployment has been initiated.

We appreciate your patience while we work to resolve the issue and apologize for the inconvenience.
Alarm Delivery is not impacted.
Posted Jul 30, 2026 - 21:08 UTC

Identified

We have identified the issue. We are in the testing phase.

We apologize for the inconvenience and appreciate your patience as we work towards full resolution.

Alarm Delivery is not impacted.
Posted Jul 29, 2026 - 20:51 UTC

Investigating

TC2 is experiencing some issues impacting functionality. This may result in intermittent errors related to SD cards, Privacy Mode settings and lagging/long loading in live stream events.

We appreciate your patience while we work to resolve the issue and apologize for the inconvenience.
Alarm Delivery is not impacted.
Posted Jul 28, 2026 - 22:20 UTC
This incident affects: AlarmNet Services (Total Connect 2.0).