Honeywell Home
Incident Report for Resideo
Resolved
Honeywell Home performance restored.
Posted Jan 19, 2022 - 12:21 UTC
Investigating
Honeywell Home performance issues
Posted Jan 19, 2022 - 12:19 UTC
This incident affected: Resideo Smart Home.