Support Phone Lines

Incident Report for Resideo

Resolved

Phone system interruption is resolved, all systems are operational.
Posted Jun 11, 2025 - 14:51 UTC

Investigating

We are aware of an issue affecting our support phone numbers.

We thank you for your patience as we work to resolve the situation as rapidly as possible.

Please accept our apologies for the disruption.
Posted Jun 11, 2025 - 14:16 UTC
This incident affected: Resideo Smart Home.