TCC Maintenance

Scheduled for Feb 3, 07:00 - 11:00 UTC

Update

We have updated the scheduled system maintenance to Tuesday, February 3 from 2:00 AM to 6:00 AM ET. During this time, the Total Connect Comfort App will be temporarily unavailable. Local control will remain fully operational throughout this maintenance window.
Posted Jan 28, 2026 - 14:54 UTC

Scheduled

We will be performing planned system maintenance on February 2, between 2:00 AM and 6:00 AM ET to ensure we maintain strong performance.

During this time, the Total Connect App (TCC) will be temporarily unavailable. Local control of your equipment will remain fully operational throughout the maintenance window.
Posted Jan 27, 2026 - 22:15 UTC
This scheduled maintenance affects: My Total Connect Comfort Application, Total Connect Comfort International Application, and Total Connect Comfort International Web Portal.