We are continuing to investigate intermittent issues with our TCC application and web portal and have made progress in identifying potential causes. Our team is actively working towards a resolution and will provide further updates as work continues. In the meantime, thermostats can still be used directly to control your heating and cooling system. We apologize for any inconvenience and appreciate your patience.
Posted Feb 03, 2026 - 23:03 UTC
Update
We are continuing to investigate intermittent issues with our Total Connect Comfort (TCC) application and web portal. Our team is working to resolve this as soon as possible. The thermostats can still be used directly to control your heating and cooling system. We apologize for any inconvenience caused.
Posted Feb 03, 2026 - 20:04 UTC
Update
We are continuing to investigate intermittent issues with our Total Connect Comfort (TCC) application and web portal. Our team is working to resolve this as soon as possible. The thermostat can still be used directly to control your heating and cooling system. We apologize for any inconvenience caused.
Posted Feb 03, 2026 - 18:36 UTC
Investigating
We are aware some of our customers are experiencing intermittent issues with our Total Connect Comfort (TCC) application and web portal. Our team is working to resolve as soon as possible. The thermostat can still be used directly to control your heating and cooling system. We apologize for any inconvenience caused.
Posted Feb 03, 2026 - 17:02 UTC
This incident affects: My Total Connect Comfort Application.